Commodore component versions

Policy

We require that all component specifications (entries in parameters.components) in the VSHN global defaults have an explicit version specification.

Rationale

Commodore v0.13.0 deprecated component specifications without explicit versions. We plan to completely drop support for component specifications without versions in Commodore v1.0.0.

Additionally, Commodore Renovate can only provide automated version updates for components which specify an explicit version in the hierarchy.

To ensure a smooth transition to Commodore v1.0.0 and to maximize the usefulness of Commodore Renovate, we now require explicit versions for all components in the VSHN global defaults. We’ve ensured that all existing components are specified with an explicit version in this merge request.

Going forward, we will enable linting of the component specifications for MRs on the VSHN global defaults repository.